# _flutterfire_internals 1.3.44

A package hosting Dart code shared between FlutterFire plugins.




## Installing
```
export PUB_HOSTED_URL=https://pub.mirror.p-hatan.com
flutter pub add '_flutterfire_internals:1.3.44'
```
Published: 2024-09-26T18:41:24.130028Z
Expected archive SHA-256: 5534e701a2c505fed1f0799e652dd6ae23bd4d2c4cf797220e5ced5764a7c1c2

Available in cache; verification: upstream_checksum
## Direct dependencies
- collection: ^1.0.0
- firebase_core: ^3.6.0
- firebase_core_platform_interface: ^5.3.0
- flutter: map[sdk:flutter]
- meta: ^1.8.0

## Package README (untrusted upstream documentation)
# \_flutterfire_internals

This package is hosting Dart code shared between FlutterFire plugins. It is not
meant for public consumption.
## Changelog
## 1.3.44

 - Update a dependency to the latest release.

## 1.3.43

 - Update a dependency to the latest release.

## 1.3.42

 - Update a dependency to the latest release.

## 1.3.41

 - Update a dependency to the latest release.

## 1.3.40

 - Update a dependency to the latest release.

## 1.3.39

 - **FIX**(web): indirect dart:js_interop conditional import to fix dart2js build issue ([#12925](https://github.com/firebase/flutterfire/issues/12925)). ([6710e999](https://github.com/firebase/flutterfire/commit/6710e9990297425e3d7c5653721dad0153f3f694))

## 1.3.38

 - Update a dependency to the latest release.

## 1.3.37

 - Update a dependency to the latest release.

## 1.3.36

 - Update a dependency to the latest release.

## 1.3.35

 - Update a dependency to the latest release.

## 1.3.34

 - Update a dependency to the latest release.

## 1.3.33

 - Update a dependency to the latest release.

## 1.3.32

 - **FIX**(web): fix type casting for JSString in error parsing ([#12698](https://github.com/firebase/flutterfire/issues/12698)). ([93efcffb](https://github.com/firebase/flutterfire/commit/93efcffbaba854fe50c5dd26b590d8a02d6e2d4e))

## 1.3.31

 - Update a dependency to the latest release.

## 1.3.30

 - Update a dependency to the latest release.

## 1.3.29

 - **FIX**(web): remove remaining references to `dart:html` ([#12601](https://github.com/firebase/flutterfire/issues/12601)). ([fbffedb6](https://github.com/firebase/flutterfire/commit/fbffedb65c180d29a07436af90b36ca56e97bfe7))

## 1.3.28

 - Update a dependency to the latest release.

## 1.3.27

 - Update a dependency to the latest release.

## 1.3.26

 - Update a dependency to the latest release.

## 1.3.25

 - Update a dependency to the latest release.

## 1.3.24

 - Update a dependency to the latest release.

## 1.3.23

 - Update a dependency to the latest release.

## 1.3.22

 - **FIX**(firestore,web): Propagate `FirebaseException` properly, fix `mergeFields` bug, fix `bytesLoaded` different type under different conditions ([#12334](https://github.com/firebase/flutterfire/issues/12334)). ([fdde75b0](https://github.com/firebase/flutterfire/commit/fdde75b02fe4bd4d40ce14798e7212eca7c8e557))
 - **FIX**(storage,web): fixed web stream handlers, e2e web tests, incorrect NativeError being thrown instead of FirebaseException on web ([#12319](https://github.com/firebase/flutterfire/issues/12319)). ([d32b5a93](https://github.com/firebase/flutterfire/commit/d32b5a936cfb05fbeeff199248474c23af293a3c))

## 1.3.21

 - Update a dependency to the latest release.

## 1.3.20

 - Update a dependency to the latest release.

## 1.3.19

 - Update a dependency to the latest release.

## 1.3.18

 - **FIX**(core,web): fix some JS interop that were incorrectly migrated ([#12239](https://github.com/firebase/flutterfire/issues/12239)). ([e38a510b](https://github.com/firebase/flutterfire/commit/e38a510b770068c1f2e4e515b7ed252f10ac2219))

## 1.3.17

 - Update a dependency to the latest release.

## 1.3.16

 - Update a dependency to the latest release.

## 1.3.15

 - Update a dependency to the latest release.

## 1.3.14

 - Update a dependency to the latest release.

## 1.3.13

 - Update a dependency to the latest release.

## 1.3.12

 - Update a dependency to the latest release.

## 1.3.11

 - Update a dependency to the latest release.

## 1.3.10

 - Update a dependency to the latest release.

## 1.3.9

 - Update a dependency to the latest release.

## 1.3.8

 - Update a dependency to the latest release.

## 1.3.7

 - Update a dependency to the latest release.

## 1.3.6

 - Update a dependency to the latest release.

## 1.3.5

 - Update a dependency to the latest release.

## 1.3.4

 - Update a dependency to the latest release.

## 1.3.3

 - Update a dependency to the latest release.

## 1.3.2

 - Update a dependency to the latest release.

## 1.3.1

 - Update a dependency to the latest release.

## 1.3.0

 - **FEAT**: update dependency constraints to `sdk: '>=2.18.0 <4.0.0'` `flutter: '>=3.3.0'` ([#10946](https://github.com/firebase/flutterfire/issues/10946)). ([2772d10f](https://github.com/firebase/flutterfire/commit/2772d10fe510dcc28ec2d37a26b266c935699fa6))

## 1.2.0

 - **FEAT**: upgrade to dart 3 compatible dependencies ([#10890](https://github.com/firebase/flutterfire/issues/10890)). ([4bd7e59b](https://github.com/firebase/flutterfire/commit/4bd7e59b1f2b09a2230c49830159342dd4592041))

## 1.1.1

 - Update a dependency to the latest release.

## 1.1.0

 - **FEAT**: bump dart sdk constraint to 2.18 ([#10618](https://github.com/firebase/flutterfire/issues/10618)). ([f80948a2](https://github.com/firebase/flutterfire/commit/f80948a28b62eead358bdb900d5a0dfb97cebb33))

## 1.0.18

 - Update a dependency to the latest release.

## 1.0.17

 - Update a dependency to the latest release.

## 1.0.16

 - Update a dependency to the latest release.

## 1.0.15

 - Update a dependency to the latest release.

## 1.0.14

 - Update a dependency to the latest release.

## 1.0.13

 - Update a dependency to the latest release.

## 1.0.12

 - **FIX**: remove unused libs from _flutterfire_internals ([#10183](https://github.com/firebase/flutterfire/issues/10183)). ([80df2d02](https://github.com/firebase/flutterfire/commit/80df2d020adec343d7cfe2c17840479cf998f631))

## 1.0.11

 - Update a dependency to the latest release.

## 1.0.10

 - Update a dependency to the latest release.

## 1.0.9

 - Update a dependency to the latest release.

## 1.0.8

 - Update a dependency to the latest release.

## 1.0.7

 - Update a dependency to the latest release.

## 1.0.6

 - Update a dependency to the latest release.

## 1.0.5

 - Update a dependency to the latest release.

## 1.0.4

 - Update a dependency to the latest release.

## 1.0.3

 - Update a dependency to the latest release.

## 1.0.2

 - **FIX**: Exceptions inside Query.snapshots() and more now have a stack trace that correctly points to the invocation of the throwing method ([#9639](https://github.com/firebase/flutterfire/issues/9639)). ([2f7adcb7](https://github.com/firebase/flutterfire/commit/2f7adcb777cd6bc4e3b5b3dd03c975c725bacef7))

## 1.0.1

 - Update a dependency to the latest release.

## 1.0.0

Initial release of \_fluttefire_internals







 
