Viewing version 2.1.0. Open the latest package page.
dds_service_extensions
2.1.0Extension methods for `package:vm_service`, used to make requests a Dart Development Service (DDS) instance.
Showing cached metadata. Upstream refresh is currently unavailable.
Readme
A package used to expand the package:vm_service interface with support for RPCs added in the Dart Developer Service (DDS) protocol.
Changelog
2.1.0
- Deprecate
DdsExtension.getAvailableCachedCpuSamplesandDdsExtension.getCachedCpuSamplesmethods.
2.0.2
- Require dart sdk v. 3.5.0 or higher.
- Add
DdsExtension.onTimerEventWithHistory. - Fix a bug that could make any
DdsExtension.on*EventWithHistorystream contain an incorrect set of events. - Remove dependency on
package:async.
2.0.1
- Update
vm_serviceto>=14.0.0 <16.0.0.
2.0.0
- Updated to DDS protocol 2.0.
- Added:
readyToResumerequireUserPermissionToResume
1.7.0
- Added:
ClientNameDdsExtension.getClientNameDdsExtension.getLogHistorySizeDdsExtension.setClientNameDdsExtension.setLogHistorySizeDdsExtension.requirePermissionToResumeSize
1.6.3
- Updated
vm_serviceversion to^14.0.0.
1.6.2
- Updated
vm_serviceversion to^13.0.0.
1.6.1
- Updated
vm_serviceversion to^12.0.0.
1.6.0
- Made DAP extensions methods accessible in lib.
1.5.0
- Added
DdsExtension.postEvent.
1.4.0
- Added
DdsExtension.getPerfettoVMTimelineWithCpuSamples.
1.3.3
- Updated
vm_serviceversion to ^11.0.0.
1.3.2
- Updated
vm_serviceversion to ^10.0.0.
1.3.1
- Updated
vm_serviceversion to 9.0.0.
1.3.0
- Moved
package:dds/vm_service_extensions.dartinto a standalone package.
Installing
export PUB_HOSTED_URL=https://pub.mirror.p-hatan.com
flutter pub add 'dds_service_extensions:2.1.0'pubspec.yaml
name: dds_service_extensions
version: 2.1.0
description: >-
Extension methods for `package:vm_service`, used to make requests a
Dart Development Service (DDS) instance.
repository: https://github.com/dart-lang/sdk/tree/main/pkg/dds_service_extensions
environment:
sdk: ^3.5.0
resolution: workspace
dependencies:
dap: ^1.0.0
vm_service: '>=14.0.0 <16.0.0'
# We use 'any' version constraints here as we get our package versions from
# the dart-lang/sdk repo's DEPS file. Note that this is a special case; the
# best practice for packages is to specify their compatible version ranges.
# See also https://dart.dev/tools/pub/dependencies.
dev_dependencies:
lints: any
Version history
| Version | Published | Archive | SHA-256 |
|---|---|---|---|
| 1.3.0 | On demand | Download | 48e539bd…a41c4c |
| 1.3.1 | On demand | Download | 5aa29ecb…f94fb2 |
| 1.3.2 | On demand | Download | 665ac32b…57d05e |
| 1.3.3 | On demand | Download | 7f6befa3…007dc7 |
| 1.4.0 | On demand | Download | db51d384…2cef77 |
| 1.5.0 | On demand | Download | 9ac669be…69ea44 |
| 1.6.0 | On demand | Download | 609d0a5d…f16d95 |
| 1.6.1 | On demand | Download | c6cc1a03…3d0f3b |
| 1.6.2 | On demand | Download | c41b86e0…ab94b2 |
| 1.6.3 | On demand | Download | 580adf64…7e22f3 |
| 1.7.0 | On demand | Download | 299ebf18…cea6d3 |
| 2.0.0 | On demand | Download | 390ae1d0…bdf1a2 |
| 2.0.1 | On demand | Download | 5a5f0f9a…568743 |
| 2.0.2 | On demand | Download | c5141143…3ec52a |
| 2.1.0 | Cached · Upstream SHA-256 matched | Download | afe0fce9…eb4d03 |
Dependencies
dap "^1.0.0"
vm_service "\u003e=14.0.0 \u003c16.0.0"